Excel Formeln

Auswahl interessanter Formeln in Microsoft Excel

Zählen

Zellen zählen, wenn diese bestimmte Werte enthalten. Beispiele:

=ZÄHLENWENN(A1:A100;"<>")       # Anzahl beliebig gefüllter Zellen
=ZÄHLENWENN(A1:A100;"A")        # Anzahl Zellen mit Inhalt "A"

Lookups

Wert in einer Wertetabelle nachschlagen. Beispiel:

=SVERWEIS(E5;A1:B4;2;FALSCH)

Erläuterung der Parameter:

  • Parameter 1: Wert, der gesucht werden soll, hier: Wert aus Feld E5
  • Parameter 2: Tabellenbereich / Matrix (Mindestens zwei Spalten), in dessen erster Spalte nach dem Wert gesucht wird, hier Tabellenbereich A1:B4
  • Parameter 3: Spalte, aus der der enthaltene Wert zurück gegeben wird, hier Spalte B
  • Parameter 4: Suchgenauigkeit: FALSCH: Exakter Wert muss vorhanden sein, WAHR: Es wird ein Wert gesucht, der dem gesuchten Wert am nächsten kommt

Führende Nullen zu Zahl hinzufügen

=TEXT(3;"00")        # Wird zu 03 konvertiert

Datum zu Monat/Jahr umbauen

Gegeben ist G4 mit 06.03.2020

=VERKETTEN(JAHR(G4);"/";TEXT(MONAT(G4);"00"))    # Wird zu 2020/03 konvertiert